×

Hello there friend! SparkFun will be closed on 8/17/2018 @2pm for a company event. We will not be offering our normal Friday tour or Local Pickups during this time. We will resume normal operations on Monday 8/20/2018. Any orders placed after 2pm MT on 8/17/2018 will be processed when we resume normal operations. Have a great day!

Member #113171

Member Since: January 7, 2010

Country: United States

  • This sounds Exactly like what was happening to me. I can barely get it to upload but when I can I either get an access point with the blink led 5 example running (that’s the only part I uploaded) or some of my code like a temp monitor plus the AP.

    A way to reliably clear these thing would be great.

  • I had some success by cranking the baud rate all the way up. Almost as if I was trying to beat a WDT reset. I’ll try the stuff above on my next one if it causes issues. So far 2 of 3 are doing it. One works fine all the time.

    Update* Got bit by a fake FTDI chip. I had ordered some 3.3/5v usb to serials on Amazon for a good price. It actually cost me 4 days of my time fighting and researching to figure out what was wrong. I had 2 of them so when I tried cables and power supplies and even a second board, I thought it had to be the Thing. Then I found I had grabbed an RFD22121 usb to serial adapter. So I rigged it to the thing. The only problem was it apparently doesn’t pull down DTR, so then I hooked the fake ftdi to the DTR on the thing, opened putty on a second com port, the Thing dropped right into download mode and took sketch after sketch. Amazing. Sometimes saving a few bucks isn’t worth it.

No public wish lists :(