Member #116805

Member Since: January 24, 2010

Country: United States

  • One question…. 4 Amp power supply? It doesn’t seem enough. For example in the blueSky() function you have: strip_a.setPixelColor(i, 0, 170, 175) over all 300 pixels. My math may be wrong but that seems to work out to over 8 amps assuming 60mA per pixel at full white (255, 255, 255). Is my assumption of 60mA for white incorrect or am I missing something else?

  • Great project! Dramatic and not too complicated although there are quite a bit of parts to bring together. I’m going to adapt it for my own ARM board so I’ll have to port all the code over. You gave enough detail so that won’t be too bad. Thanks!

  • Ok. Got it. The /CS pin was not being set high at startup. I had commented that line out by mistake when I commented out a whole block of code. First read is working properly.

  • Looks like the first read can also be complete garbage. I’ve noticed that all I have to do is toggle the /CS pin and the first read after that will be fine. Very reproducible.

  • Great board. Great part. I have it working solid on a STM32F4 using DMA. 33us to read the time and date! Not bad.

    One observation I have and I’m just wondering if anyone else has seen this. The very first read after startup comes back wrong by anywhere from 2 to 6 seconds. Every read after that comes in perfect. The datasheet says the buffer registers are sync’d on the falling edge of /CS but that doesn’t seem to be the case for the very first read.

    Anyone else?

No public wish lists :(