Member #1581901

Member Since: March 2, 2020

Country: United States

  • Hi, I bought one and unfortunately there is installed very old version FW from 2016 without AT+CIUPDATE command hence is difficult to update it. I recommend install newest one, please.

No public wish lists :(