avatar

Member #384877

Member Since: November 30, 2012

Country: Mexico

  • Product ROB-12075 | about 2 months ago

    Well command mode is $$$ indeed, have you checked the Tx Rx connections?, you can try to connect the BT module to an arduino with an empty loop and use the serial monitor to communicate with it (and check for other baudrates).

  • Product ROB-12075 | about 2 months ago

    Well, I just got rid of the setup code for the BT device, and used the baudrate of my module in the Bluetooth.ino file (replace the BluetoothConfig function):

    void BluetoothConfig()                                         // This code intended for a DAGU bluetooth module - may not work with other brands
    {
      Serial.begin(115200);
      mode=2;
    }
    
  • Product ROB-12075 | about 5 months ago

    Yep, forgot to comment, I’ve tested with the jumper on low voltage mode and without.

  • Product ROB-12075 | about 5 months ago

    Did a simple check with the multimeter and saw that both the H-Brides outputs are connected together, so I checked your image from the back of the PCB and my PCB, mine has solder making connection between both FETs.

    Could that be the problem?
    Should I disconnect them?
    If so what would be the best method?

    Thanks.

  • Product ROB-12075 | about 5 months ago

    Hi, I’ve got some problems with this controller, I’ve changed the code for the bluetooth to be compatible with the BlueSMiRF Silver (WRL-10269), connected to the Wild Thumper 6WD (ROB-11056) then connected a 7.4V LiPo (PRT-10471) to the controller. I get the correct beeps for the mode 2, but when I pair with the Android app the motors start to glitch, and the controller resets if I try to drive them with the app.

    I ran the diagnostic mode on the controller (just the controller, no battery, BT nor motors) and got these results (excerpt):

    Battery voltage: 425 X: 504 Y: 639 Z: 637 Lmotor current: -48mA Rmotor current: 48mA PWM:240
    Battery voltage: 425 X: 499 Y: 638 Z: 636 Lmotor current: -48mA Rmotor current: 48mA PWM:245
    Battery voltage: 425 X: 500 Y: 640 Z: 638 Lmotor current: -48mA Rmotor current: 0mA PWM:250
    Battery voltage: 437 X: 522 Y: 600 Z: 601 Lmotor current: 781mA Rmotor current: 830mA PWM:255
    Battery voltage: 422 X: 501 Y: 633 Z: 632 Lmotor current: -48mA Rmotor current: 48mA PWM:250
    Battery voltage: 425 X: 498 Y: 638 Z: 636 Lmotor current: -97mA Rmotor current: 0mA PWM:245
    Battery voltage: 425 X: 499 Y: 639 Z: 637 Lmotor current: -146mA Rmotor current: -48mA PWM:240
    Battery voltage: 425 X: 505 Y: 639 Z: 638 Lmotor current: -97mA Rmotor current: 0mA PWM:235
    Battery voltage: 425 X: 504 Y: 640 Z: 638 Lmotor current: -97mA Rmotor current: 0mA PWM:230
    Battery voltage: 425 X: 511 Y: 640 Z: 638 Lmotor current: -97mA Rmotor current: 0mA PWM:225
    Battery voltage: 425 X: 508 Y: 640 Z: 638 Lmotor current: -97mA Rmotor current: 0mA PWM:220
    Battery voltage: 425 X: 508 Y: 640 Z: 638 Lmotor current: -48mA Rmotor current: 0mA PWM:215
    Battery voltage: 425 X: 500 Y: 640 Z: 638 Lmotor current: -48mA Rmotor current: 0mA PWM:210
    Battery voltage: 425 X: 502 Y: 640 Z: 637 Lmotor current: -97mA Rmotor current: 0mA PWM:205
    Battery voltage: 428 X: 503 Y: 640 Z: 638 Lmotor current: -48mA Rmotor current: 0mA PWM:200
    Battery voltage: 425 X: 499 Y: 639 Z: 637 Lmotor current: -97mA Rmotor current: 0mA PWM:195
    Battery voltage: 428 X: 503 Y: 640 Z: 638 Lmotor current: -48mA Rmotor current: 0mA PWM:190
    Battery voltage: 425 X: 502 Y: 640 Z: 639 Lmotor current: -48mA Rmotor current: 48mA PWM:185
    Battery voltage: 428 X: 504 Y: 640 Z: 639 Lmotor current: -48mA Rmotor current: 48mA PWM:180
    Battery voltage: 428 X: 501 Y: 640 Z: 639 Lmotor current: -48mA Rmotor current: 48mA PWM:175
    Battery voltage: 428 X: 506 Y: 639 Z: 638 Lmotor current: -97mA Rmotor current: 0mA PWM:170
    Battery voltage: 428 X: 509 Y: 640 Z: 639 Lmotor current: -48mA Rmotor current: 48mA PWM:165
    Battery voltage: 425 X: 500 Y: 639 Z: 638 Lmotor current: -97mA Rmotor current: 0mA PWM:160
    Battery voltage: 428 X: 497 Y: 640 Z: 639 Lmotor current: -48mA Rmotor current: 48mA PWM:155
    Battery voltage: 425 X: 495 Y: 640 Z: 639 Lmotor current: -48mA Rmotor current: 48mA PWM:150
    Battery voltage: 428 X: 498 Y: 640 Z: 639 Lmotor current: -97mA Rmotor current: 0mA PWM:145
    Battery voltage: 425 X: 501 Y: 641 Z: 639 Lmotor current: -48mA Rmotor current: 48mA PWM:140
    Battery voltage: 425 X: 503 Y: 639 Z: 638 Lmotor current: -97mA Rmotor current: 0mA PWM:135
    Battery voltage: 428 X: 505 Y: 641 Z: 639 Lmotor current: -48mA Rmotor current: 48mA PWM:130

    You can notice a few 700mA to 800mA at some times in the motors (without the motors plugged).

    When plugging just the LiPo to the controller I hear some noises near the 5V LDO regulator and the capacitors, I’ve tested the Wild Thumper motors and they seem to work fine.

No public wish lists :(