×

SparkFun Electronics will be closed on November 26, 2020 and November 27, 2020 for the Thanksgiving holiday. We will begin normal operations at 9:00 AM Mountain Time on November 30, 2020.

×

Please see all COVID-19 updates here as some shipments may be delayed due to CDC safety and staffing guidelines. If you have an order or shipping question please refer to our Customer Support page. For technical questions please check out our Forums. Thank you for your continued support.

DClapp

Member Since: November 12, 2008

Country: United States

  • I'm also having problems with SD card init starting with v1.5 firmware.
    Some cards don't work at all; others only sometimes.
    Getting the serial port spitting out messages at 115200, I see a variety of bad responses, "no SD Card detected", "Failed Reading Header" and - my personal favorite - "sd_raw_read borks"
    If I get this working, my next question is about turning the GGA message back on. Since the parsing routine is in there - is there any reason this shouldn't work witht he EM-408?

  • Powerful little board!
    I had to read the source to figure out which of the UARTs to use. Unless I missed it, the datasheet does not explicitly tell you to use the UART0 pins. My first guess was that that was reserved for debug and ISP programming.
    Let me add my vote for new hardware features:
    RTC Vbatt pad option
    more pads for currently unused pins if there is room
    On the software side, mixed UART and ADC (I know, just a few lines of code I could do myself...) and RTC support.

No public wish lists :(