JeffRule

Member Since: June 22, 2014

Country: United States

  • OMG, I have been going crazy with this.

    I have a project where I am using the signal pin to drive the gate of a MOSFET and calling the Tls.clearAll(), turns everything on. And setting the values to chanel values to 4095 turns it off.... I was sure I had connected something up incorrectly. Thank you for this bit if information.

    I was seeing one other thing values in the middle of the 0-4095 range were getting stronger then weaker then stronger again, it was not appearing to produce an ever increasing PWM signal. I will do some more testing and post back here when I know more.

  • I want to cut the 'trace' for the midi-in so I can use that pin for PMW output. This is described on the main hookup guide page. However I can't quite figure out what exactly I am supposed to cut.. The board layout next to the label for the pin looks approximately like the (crude) drawing below.

    /---\
     0 0  
    \---/
    

    Do I cut one of the loops above or below the two solder pads or both the loops above and below the solder pads. Or is there some connection between the solder pads that I am not seeing with with with my magnifying glasses that needs to be cut?

  • I am pairing this shield in a project with the Sparkfun MP3 shield which already requires use of pins D2/D3. The docs indicate I can use different digital pins if I would like. I have looked at the doc and I don’t see any examples of how to route the xbee shield to use pins other then D0/D1 (don’t want to do that way too inconvenient for programming) or D2/D3 (already used by my other sparkfun shield). What are my options on re-configuring the board to use pins D5/D10 for TX/RX. I don’t want to simply jumper D2/D3 -> D5/D10. I need D2/D3 to be left open for the other shield to use. Is that configuration possible with this shield?

  • I am pairing this shield in a project with the Sparkfun MP3 shield which already requires use of pins 2 and 3. The docs indicate I can use different digital pins if I would like. I have looked at the doc and I don't see any examples of how to route the xbee shield to use pins other then D0/D1 (don't want to do that way too inconvenient for programming) or D2/D3 (already used by my other sparkfun shield). What are my options on re-configuring the board to use pins D5/D10 for TX/RX. I don't want to simply jumper D2/D3 -> D5/D10. I need D2/D3 to be left open for the other shield to use. Is that configuration possible with this shield?

No public wish lists :(