TravisGood

Member Since: January 4, 2009

Country: United States

  • Product DEV-08778 | about 5 years ago

    I’ve read that this works with firmware 1.x and requires a jailbroken iPod touch.
    Is this true?
    If not then can I used it with my firmware v.2.2 non-jailbroke iPod touch?

No public wish lists :(