Creative Commons images are CC BY-NC-SA 3.0

14.95

added to your
shopping cart

quantity
In stock 47 in stock
14.95 1+ units
13.46 10+ units
11.96 100+ units

Skills

Description: The LilyPad XBee is a breakout board for the popular XBee modules. Board includes easy-to-sew tabs and all the necessary power regulation to run on the LilyPad system.

LilyPad is a wearable e-textile technology developed by Leah Buechley and cooperatively designed by Leah and SparkFun. Each LilyPad was creatively designed to have large connecting pads to allow them to be sewn into clothing. Various input, output, power, and sensor boards are available. They're even washable!

LilyPad XBee was co-developed by Kate Hartman and Rob Faludi. It works with all the popular XBee module types but does not ship with a module. Please see the related items below.

Note: This LilyPad board does NOT include and XBee module.

Note: A portion of this sale is given back to Dr. Leah Buechley for continued development and education of e-textiles and to Rob Faludi and Kate Hartman for product support and continued development.

Dimensions:

  • 50mm outer diameter
  • Thin 0.8mm PCB

Documents:

Comments 30 comments

  • Do Arduino soft is able to interface the maxstream ?
    Or, is there a project for linking the two components ?

  • Excuse me, but is the Xbee module included or this is only the “board” in which I can put the Xbee module?

    • Shoot, you’re right! The photos don’t make that very obvious. This product is for the PCB breakout board only. You’ll need to order the XBee of your choice. I’ll ask to get the photos updated as well!

  • I have this working with a Lilypad and rn41xv hosted on the card – but only if I use pin 0/1 (rx,tx) of the Lilypad – I have not been able to communicate with the rn41xv using the softwareserial library at any combination of baud rate or various pins. Has anyone out there been able to get this to work with softwareserial on the Lilypad? … btw, i have also managed to switch the rn41xv it to HID profile and can pair with my iDevices as a keyboard to log data or drive simple ios apps like magic monitor. IT WOULD BE VERY HELPFUL to be able to move it off the rx/tx pins to facilitate programming and debugging … .

  • okay, had to give up on this product after a few frustrating weeks. It is very finicky about its power supply (you’ll need to feed it between 3.3 and 5V), finally rigged up a power supply that it liked, had it working for a day, and then it died. Going back to my Uno shield…

  • Are there any clear directions, perhaps diagrams, on how to connect this to a Lilypad Arduino? The “additional information” site does not contain any except for a graphic used in a different project that involves an RFID, and uses pins 2 and 3 on the Arduino instead of rx and tx. I currently have rx to rx, tx to tx, power to power and ground to ground between the xbee and the lilypad but it’s a no go. Any additional resources or advice? I have been scouring the internet for solutions/testing for 3 days…

    Could it be that the lilypad power supply, which uses AAA battery, does not deliver enough power for both the xbee and the arduino? They both appear to be powered when wired to it…

    • Double check the actual directions of the TX and RX on both your boards. In many cases you need to connect TX to RX and RX to TX.

      • Also tried that earlier, and tried it again just for good measure. I still don’t seem to have communication between the two.

        • Do you by chance have the FTDI programming board plugged in while you’re doing this?

          I ask because it will interfere with any other uses of the serial port. This is why people often use softwareserial on 2 and 3, to keep clear of the hardware serial port on 0 and 1.

          If you’re writing a sketch that e.g. sends a test pattern out the serial port, and are running it on battery without the FTDI plugged in, that’s the right way to do it and to the best of my knowledge it should be working.

          • Thanks for your response. I programmed the lilypad using the FTDI but then removed it to test the Xbee functionality. I know it’s not a problem with my sketch because it works using the Uno and it’s corresponding Xbee shield.

            Do you think this is a power problem? I am using the Lilypad Power supply with the AAA battery, and while I suspected it was not enough power, everything seems to be illuminated - the Lilypad, the Xbee, and the LED I am testing. I am not sure if insufficient power supply would illuminate everything but not allow it to function - I thought that if power was insufficient, it would just fail to illuminate.

            Thanks again.

            • Sorry about the problems. Are you getting any lights on the XBee module?

              • Also, can you verify that the LilyPad Arduino is working properly, for example by blinking the LED on D13?

                • Also (sorry) from something you wrote above, you should have four wires going to the XBee: 5V to the “+” pin, ground to the “-” pin, and TX and RX.

                  • Yes I am getting the blinking red LED on the Xbee (and I went ahead and connected + to 5V even though it still lit up without it). I am also getting the green LED on the Lilypad. Is it possible that the AAA battery is enough voltage to power the Xbee but not communicate with the Arduino?

                    • It’s possible that the AAA can’t supply enough power to both, especially if it’s a weak battery, etc., but it should work. The XBee is the thing here that needs the most power. Be sure you’re using a fresh battery.

                      You definitely need the 5V line to the XBee. It may appear to work (light the LED) without it because it’s stealing some power from the Arduino’s TX line, but that probably isn’t enough to transmit.

                      Can you send the “blink” sketch to the Arduino and verify that you can blink the LED? If you run your sketch with the XBee disconnected and the FTDI connected, can you see your output (that’s supposed to go to the XBee) in the Serial Monitor window?

                      If you have a multimeter, check that you’re getting close to 5V where it’s supposed to be. If you’re sewing the connections, it’s easy to have a partial connection. If you have some alligator clip jumpers, you can clip them to the sew taps for temporary connections to see if everything’s working.

                      Which XBee are you using?

                      Sorry this is such a hassle, we’ll do our best to get you up and running!

                      • Sorry it took me so long to get back to you. I think something is off with the lilypad, when I had it plugged into my computer with the FTDI it kept shorting out my USB. Then I tried to program the Blink sketch onto it (I had initially gotten the blink sketch to work after reading your comment but I had gone back to check the serial monitor) and now arduino is telling me that the program is not responding and will not let me upload any sketches to either the lilypad or the uno. I tried restarting the computer to no avail. So I think that the lilypad might have damaged my USB ports.

                        So I guess now I have a different problem! Any advice?

                        • It shouldn’t be possible for USB ports to be damaged by the LilyPad. But it is possible to lock up the FTDI board, requiring you to unplug it and replug it. Also note that you won’t be able to upload any sketches while you have the XBee connected to the Lilypad (unless you use softwareserial and put the XBee on different pins than RX and TX).

                          Again, sorry for the frustrating experience. Since things are acting so oddly for you, you should contact our tech support department for help. Some pictures of your setup would likely help them debug what’s going on.

                          • I’ve been in touch with tech support but I have only heard from them once since I contacted them a few days ago, and obviously this is an ongoing problem. I’ve been disconnecting the xbees for when I upload sketches since I knew you couldn’t keep it connected. Perhaps somehow both my arduinos are damaged, not sure how that happened since the Uno was working fine before the problem started with the lilypad. I’ll see if I can find a solution somewhere. Thanks for your help.

                        • and I am using the xbee series 1 (not pro)

    • okay just discovered you don’t need power to power with the xbee because of the capacitor you just need ground. Got a little closer but still can’t control it from my sketch…

  • I’m quite new also. What is your recommendation about an xbee Bluetooth module to connect lilypad with Android phone? Thank you in advance ;-)

  • I am new to Lilypad and Arduino. Do we need to buy XBee adapter separately? Also is there a tutorial to communicate a LilyPad with an Ardunio with Ethernet

    • No absolute need for a separate XBee adapter, though it might be useful in configuring the XBee directly. Also if you’re trying to get your XBee on the Internet, then check out the XBee Internet Gateway

  • Will this sit on a Lily SimpleBoard, or do I need to get the standard Lily board?

  • Ok, something else I just noticed. The silk screening on here says 3.3V, which is what the XBee needs. However, using a Lilypad with a LiPower module (http://www.sparkfun.com/products/8786) puts it at 5V - the LiPower doesn’t provide anything else other than a direct connection to the LiPo being used (3.7V). So, is there an “in-between” that brings that 5V down to the 3.3V that this breakout (and the XBee) uses?

    • The 3.3V pin is an output from the 3.3V voltage regulator. The input pins are at the other end of the board.

  • Does a Series 2.5 work with this breakout board?

    • Yes, the “Series 2”, “Series 2.5” “ZNET” or “Zigbee” version (all the same thing) will work fine.
      All the Xbee modules are pin compatible and work in all the products. You just can’t make an 802.15.4 (Series 1) module talk to a Zigbee (Series 2) module and vice versa.
      Keep all your modules of the same series and everything will be fine.

  • Yeah, now i can add a ground station to my jacket..


Related Products